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Torchmate Version 4 Multi-Tool Set up Guide

This guide will walk you through how to properly set up your software
for multiple tool actions during a single program.

First, you will want to open up Torchmate CAD (Version 7.1.1, 8.1, or
EDU is compatible). Go to [Machine > Tool Library]
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Next you will notice the current tools you have in your library.

-
Tools Library u
~Mame ~ Tupe Parameters
Flasma Plasma ~|| D1 0.059
Duyp-dicetylens Turret 1
Color N -
Pricrity 1
[ Filter By Type
[ sad | Updae || Dekre |

This is where you will add your Plate Marker tool. To create a new tool,
simply start typing in the “Name” box. After typing in Plate Marker,
click on “D1” which is highlighted below. Change “D1” to “0.030".

-
| Teols Library u
~Name Parameters
Flate b arker
Ouy-Acetylens
Plazma
Pricrity
[~ Filter By Type
[ add  |[ Updaste |[ Deler= |




Hit the “Enter” key on the keyboard and it will turn blue. Now click on
“Turret” and change it to “2” and hit “Enter” on the keyboard.

P
|| Tools Library u

~Name ~Type Parameters| |
Plate Marker I Pla
Dup-dAcetylens
Flazma
Pricrity
[ Filter By Type

[ add | Update |[ Dol |

Finally, click on “Add” and you will notice the Plate Marker will be
added to the list.
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~Name ~ Type P‘arameters| |
Plate M arker Plazma ;I
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Plazma

Plate ki arker
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Now go to [Machine > Machining Defaults]
] lorchmate CAL-CAM
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Click the arrow on “Selected Driver” and scroll down to “Torchmate
Dual Tool Driver” and select it. Now click “Apply” and you’re done!
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For the next phase of the setup, you will work in the Torchmate 4
Driver Software. Navigate to [Configuration > Programming > M-Code
Definitions].

m Torchmate - Mo G-Code File Open - TorchmateX-Stepper.5TP - Terchmate.tlg .

File Edit | Configuration | Controller View Coordinates Favorites  Help

Edit...

Systemn 3 A TE‘

Machine LI Eiectric Company Not Connected
Yo 3

Programming 2 M-Code Definitions...

Tools 2 M-Code Execution...

Sensing L G-Code...

Preferences * User Variables...

Counters...

Cutter Compensation...

Import...

Cycles...

On the next screen you will notice a list of M-Codes and their
descriptions.

rﬁgrammmg General
- M-Code Execution b B e iian
- G-Code —
- Ugzer Wariables Plazma On
- Courters Flazma DFf
- Cutter Compenzation Plate Marker On
~ |mpart Plate Marker Off
- Cpcles Dy On
“oolz Oy OFF
- Tool Library
- Tool Life Management
Tmml Tl mimmm




You will need to change the “50” to “22” and “51” to “23” so that it
looks like the picture below:

e e e e ——————

Programming

B t-Ciode Definitions General
- h-Code Execution ] Descript
- G-Code Code ezcrption
- Uzer Wariables o2 Flazma On
- Counters 23 Plasma OFf
- Cutter Compenzation s o
- | rnpiart 53 Flate Marker Off
- Cypcles h4 Owy On
Taals AR Dy OFf

Next you will move down that same screen and change the “22” to “50”
and “23” to “51” so that it looks like the picture below:

b-Codesz to Control Output Lines [For Line Columns: 1'="
eneral Ar
M - Frogram | M-Code Delay | Ln. | Ln
Descrptian Line First First
Legs i Actian Action [sec] L -
27 Plazma On bd-Cd Setln |01 1
23 Plazma OFf -Cd Setln |1.0 ]
A Plate karker On b-Cd Setln |02 -
a3 Flate Marker Off -Cd Setln 1.0
a4 Oy On -Cd Setln | 3.0
55 Oy O k-Cd Setln 1.0
k-Cd Setln |00
i k-Cd Setln |00
-Cd Setln 0.0
bd-Cd Setln |00
-Cd Setln |00
o
t-Codes to Esecute Macros
Program ]
= rll‘:alnde Description Macro LEBQ_First S:jtl?:!
chion
M-Cd |Mao
M-Cd  |Mo
kM-Cd  |Mo
M-Cd  |Mo
M-Cd  |Mo
| I Ldma k-
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Now you will need to edit the macro associated with those M-Codes
(50 and 51). If you click on the text that says, “IF #URRTOO...” then a
pop up arrow will appear.

' KT
M-Codes to Execute Macroz

Frograrm . .

Elude Deszcription Macro Line First Display in

Action

-~
Ltput Box J

20 Plazra Only IF #aWHC =

22 Fulit Toal Start -

23 bulti Tool Stop IF #CURRTOO. .. b
t-Cd a
M-Cd [Ma
M-Cd [Ma

Click on that arrow and an “Edit M-Code Macro” window will pop up.

IF #CURRTOOL = 0 THEN -
00 "Mo Tool Selected”

ELSEIF HCURRTOOL =1 THEM
50
107 17 "Moo Fierce Signal From ayHC"

ELSEIF #CURRTOOL = 2 THEM
M52

ELSEIF #CURRTOOL = 3 THEM
GE04 sHpreheat
54

ELSE
MO0 "lrvalid Tool Selected”

EMNDIF

0k Cancel
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Where it says,
ELSEIF #CURRTOOL = 1 THEN
M50

M101 11 “No Pierce Signal From AVHC”

Change the “50” to “22” so it looks like the picture below:

IF #CURRTOOL =0 THEM
FO0 "Ma Tool Selected"

ELSEIF #CURRTOOL =1 THEM
M2
k101 11 "Moo Pierce Signal From AWHC"

M52

/| |ELSEIF HCURRTOOL = 3 THEN
G014 wHprebeat
k54

ELSE
k0D "revalid Tool Selected

EMDIF

| ] Caricel




Click “OK” and then open the “Edit M-Code Macro” window for M-Code

23.
M-Codes to Execute Macros
Frogram ] ] -
rlglnu:le Crezcription Macro Li;"ne First gﬁtl:ll:lzfénn:-: J
chioh

20 Plazrma Only IF #&WHC = M-Cd  |Mo
22 ulit Tool Start IF #CURRTOO. .. b -
23 |Multi Taal Stop IF #CURATOC. . [

k- a

M-Cd [Ma

You should see this:

IF #CURRTOOL =0 THEN -
MO0 "Moo Tool Selected"

ELSEIF #CURRTOOL =1 THEM
Ma1

ELSEIF #CURRTOOL = 2 THEM
M53

ELSEIF #CURRTOOL =3 THEM
i 55

ELSE
k00 "lreealid Tool Selected"!

EMDIF

| ] | Canicel
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Where it says,
ELSEIF #CURRTOOL = 1 THEN

M51

Change the “51” to “23” so it looks like the picture below:

IF #CURRTOOL =0 THEM
MO0 "Ho Tool Selected"

ELSEIF #CURRTOOL =1 THEN
M23

ELSEIF #CURRTOOL = 2 THEN
ME3

ELSEIF #CURRTOOL = 3 THEM
il M55

ELSE
k00 "lrvalid Tool Selected”

EMDIF

| F, Cancel
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Click “OK” and then navigate to the “M-Code Execution” screen show
here:

- Dutput Lines .| M-Code Execution [ Display Sharteut

i Wariable Output
=)+ Programming

- M-Code Defivitions " Mone After Limit/S afety/S pindle Errar; M
M/ Code Execution ‘ Basic
- [3-Code

- Ulser Variables Start [After Hold} M Execute at Start/End of Mation
- Counters Feed Hold: M Start of Motion: M

- Cutter Compenzation

Automatic Execution Mode Emecute After Motion Ermarz

- | mipart e Ful End of Mation: M
- Cycles Feedrate Mave: M |20
= Taols ; i
- Taal Library Al Other Times: M [51 Ezei ke s
- Tool Life Managemeant Beginhing of Ramp: M
- Tool Change
- Tools in Changer Execute When [die End of Ramp: M
[l Sensing

- Tool Length Sensing On Feed Hold/Safety Tripped: M

- Pragram Zero Sensing
- Touch Probe

. Emecute wWhile Connecting/Dizconnectin
On Change of Input Line State e g

= Preferences Input State Enecute | = Connecting: M ’_
- Main Screen 3 i - -Gt . .
. Mone = Tripped Digconnecting: M ’_
UIE_WDE!HS Mone Tripped
F'Dlnt. Ligt None Tripped
- Juaging Mone Tripped |
- Pandant
- Files
- Messages
- Security
- [eneral

-

Ok, | Cancel ‘

Notice where it says “Full” and change “Feedrate Move” from “20” to
”50”-

Automatic Esecution bode

(" Mone
" Basic
Start [after Hold): b

Feed Hold: M
= Full

Feedrate Move: M |50

All Other Times: M |51

(
{
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Click “OK” in the bottom left of the screen

i Configuration

Output Lines .| M-Code Execution [ Digplay Shortout
- Wariable Cutput Autornatic Execution Mode Execute After Motion Ermrars
=+ Programming
. M-Code Definitions " Mone After Limnit/S afety/Spindle Enor: M
- " Basic
- G-Cod )
i St (4l e ls |1 Execute at Start/End of Mation

-~ |Jzer Yaniables

- Counbers Feed Hold: # Start of Motion:
- Cutter Compenzation

- | mport f* Full End of Motion: b

- Cycles Feedrate Mowve: M |50
= Tools - ;

- Tool Library All Other Times: M [51 Ll Dl e i

- T ool Life b anagemant Beginning of Famp:

- Tool Change

- Tools in Changer Execute When |dle End of Ramp: M
[=]- Sensing .

- Taol Length Sensing On Feed Haold/Safety Trippad: M

- Program Zero S enzing On Change of Input Lin State Execute While Connecting/Disconnecting

~ Touch Probe Connecting:
El- Preferences 1 :_Trfgtﬁ State E;:'ECDLSE i '

- Main Screen 1 Mone  =| Tripped J Digconnecting:

- Wiewparts :

P MHone Tripped

F'olnt. List Mane Tripped

- Jogging Mone Tripped -

- Penidant

- Filez

- Meszages

- Security

- [eneral

o |-gimmm

You will want to save your setup at this point so that you won’t have to

make this change again. To do this, go to [File > Save Setup].

Torchmate - Mo G-Cede File Open - To

File | Edit Configuration Controller !
Mew G-Code... Ctrl+M
Open G-Code... Ctrl+0
Close G-Code

Mew Setup...
Open Setup...
Save Setup
Save Setup As...

Mew Tocling...

Mren Tanlinn
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As a precaution, we also recommend making a backup file of this setup.
To do this, go to [File > Save Setup As]. When naming the file, just add
“BACKUP” to the end and save it. Then to go [File > Open Setup] and
open up your original setup file. Now in case something happens to the
original, you can always load the backup and be okay. Additionally, we
recommend you save these two setup files to a USB flash drive or
external hard drive. This way you will be covered if your computer
crashes or is otherwise not operational.

Now, if you haven’t setup your tool offset yet, | will explain how to do
that now. Jog your torch over a piece of material and zero your
program coordinates (Click on “SET” and then click “Zero All”)

Zero All

Zero X
Zero ¥

Enter...

Cenfigure Fidure Offsets...
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Go to the “AUX” menu and turn your plasma from OFF to ON

Program |[hestis]

X 0.0000
Y 0.0000

Machine [NSeiie

X N/A
Y N/A

Program [Hostis)

X 0.0000
Y 0.0000

Machine [hSeiie)

X N/A
Y N/A

Plasma (On)

Hold

14
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Once you see sparks, turn the plasma off.

——
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Program [NS&is

X 0.0000
Y 0.0000

Machine [S&i=

X N/A
Y N/A
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Now jog the machine until your plate marker is exactly over the pierce
hole. You may want to bring the plate marker down physically and see
if it dives exactly into the middle of that hole as shown below:

Once the plate marker fits in the pierce mark, go to [Coordinates >
Define Tool Offset]

ﬂ Torchmate - Mo G-Code File Open - Terchmate2x2Plasma.STP - delmate.tlgﬂ
File Edit Configuration Controller View | Coordinates | Favorites Help

Zero Program

Zero Machine

Zero Relative

Enter Program...

Tarch: Enter Relative...
Pierce Delay: Clear Machine

Define Fidure Offset...
Define Tool Offset..,

Define Reference Point...
Define Tool Rack Position...

AYHC? (TIF)

Use Safe Envelope

(
{
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Make sure to click on “Plate Marker” and that X and Y are checked as
shown below:

A Define Tool Offse .

Use DRO Tool

#1 - Plasma
#2 - Plate Marker
'S #3 - Oxy Fuel
#4

™ Relative #5

#6

#7

#3

#9

#10

#11

#12

#13

#14
#15

* Program

Description: |F'Iate Marker

Set

If the “Define Tool Offset” window looks like what is pictured before,
click on “Set”.
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Finally, go to [File > Save Tooling]

E Torchmate - Mo G-Code File Open - Torchmate2

File | Edit Configuration Controller ‘-Eew Cc
MNew G-Code... Ctrl+M
Open G-Code... Ctrl+0
Close G-Code

Mew Setup...
Open Setup...
Save Setup
Save Setup As...

Mew Tooling...
Open Tooling..
Save Tocling

Save Tocling As...

Editor... Ctrl+E
Import DXF... Ctri+I
G-Code Properties...

Recent Setup [

Recent Tooling r

Exit

It is also important to create a backup of that file as well. You are now
ready to create multi-tool files and run them inside Torchmate 4.
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Now to actually add the Plate Marker to your tool set. Go to
[Controller > Output Line Control]

Line Description State Line
1 Plasma Off | 17
2 off | 18
3 i | 19
4 off | 20
5 off | 21
] off | 22
[ i | 23
8 off | 24
9 off | 25
10 off | 28
il i | 27
12 off | 28
13 off | 29
14 off | 30
15 i | 31
16 off | 32

|

From here, start clicking the “Off” buttons starting at “2” one at a time.
If you already have your Plate Marker set up with air, it will activate the
Plate Marker. If not, then you should hear the click coming from the
Torchmate Universal Relay. If you do not hear a click or your Plate
Marker does not fire, then just move to the next line and activate it.
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Now that we know which line it’s on. Go to [Configuration > 1/0 >

Output Lines]. Type in “Plate Marker” on the line it was activated on.

For the sake of this guide, I’'m going to say it was on line two. It should

=- 140

- Input Lines

- W ariable Qutput

- Pragramming

- M-Code Definitions
- M-Code Execution
- G-Code

- Uger Wariables

- Counters

- Cutter Compensation
- [mpart

- Cycles

- Tools

- Taal Library

- Tool Life Management
- Tool Change

- Tadls in Changer

- Senzing

- Tool Length Sensing
- Program Zera Sensing
- Touch Probe

- Preferences

- Main Scraen
- Wigwparks

- Point List

- Jogging

- Pendant

- Files

- Mezsages

m

look like this:

DOutput Lines [~ Dizplay Shartcut
. . Button Text Dizplay Dizplay in Dizplay in
Line # | Description [replaces Description] W arning Ay Panel | Output Box
ﬂasma Before ﬁn Tes Tes
2 |Plate Marker Before On Tes Tes
3 betare Un S MNo -
4 Before On Tes Mo
] Before On Tes Mo
5 Before On Tes Mo
7 Before On Tes Mo
8 Before On Tes Mo
g Before On Yes Mo
10 Before On Tz Ma
11 Before On Tes Mo
12 Before On Tes Mo fr
13 Before On Tes Mo
14 Before On Tes Mo
15 Before On Yes Mo
16 Before On Yes Mo
17 Before On Tes Mo
18 Before On Tes Mo
19 Before On Tes Mo
20 Before On Tes Mo =

Salety Interacks (lnwvalid Dutput Line Carmbinations]

Cutput Cutput -
Line # Set To Line SetTo J
Mone  =10n Mone On

MNone On Mone On

Mone On Mone On

——
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Now make your way down to your M-Code Definitions one last time.
You'll need to add on/off commands on the appropriate line. If your
Plate Marker is on Line 2, then it should look like this:

f mEmmE tm mEriE e E———— g om G m e PSP

General Action
Program | M-Code
rgn de Drescription LEEQ_First Fir_st [[]: ;ac‘lil I_-ln. LG' L3n.
chion Actian
=0 Plazma On k-Cd Setln |01 1
a1 Plazma Off kd-Cd Setln |1.0 ] -
52 Plate karker On kd-Cd Setln |02 - 1
q3 Plate b arker OFf kd-Cd Setln |1.0 - |p -
a4 Qe On kd-Cd Setln | 3.0 - -
a5 Doy O b-Cd Setln 1.0
b-Cd Setln |00
k-Cd Setln |00
k-Cd Setln |00
k-Cd Setln |00
kd-Cd Setln |00

Once that is done, click OK in the bottom left and then go to [File >
Save Setup]. You should be all done here in the Driver Software for
Now.

21

——
| —



Now we need to create a Multi-Tool file. The part you will be making is
going to be very basic, but will help you understand the fundamentals
of multi-tool programs. First, start by creating a rectangle. Any size will

do.
3 = £l
T
i O i
[ = |

11 e 1 P P S =) PR (P P P P 2 o e e[ (I [ 1P 200 o1 eI I 1 1 [ 31 [ T Pl = P

Now create a circle inside of that rectangle. Again, any size (as long as it
fits inside the rectangle) will do.

: None

ulssienloaleelmal o cleslaolpplprlcoleolenleniealms e e el coleolezal cc) = == e =
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With the circle selected, go to [Machine > Create Tool Path > Online].

File Edit Layout Arrange [Machine] Transform  Image View Options Help

Output. AlteP ey 2226 4 100000 ¢ ot
Machining Defaults T 2206 i' 100000 s =
Tool Options... 1
Tiling.. s @ & @_. ﬂ.
I BTSRRI BN S S AT R
Cut Ternplate...
Teool Library...
Material Library...
Use Easy Templates
Cut Ternplate Wizard
Create Tool Path L Online...
Apply Tool Path 2 Male...
Delete Tool Path Femnale...
Edit Tool Path... Fill...
Convert To Online Tool Path Torch Path .
Edit Start Point Drill Matris...
lob Analysis Drill Centour...
Object Total Area Drill Center...

Drill Corner...

***please note, if you do not see “Create Tool Path”, uncheck “Use Easy Templates”***
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(1)Select “Plate Marker”. (2)Make sure your direction is set to
“Conventional”. (3)Enter in your feed rate. It is important to remember
that your feed rate MUST be entered in at this screen. Otherwise the
program will not work when opened inside the Torchmate software. A
feed rate anywhere between 25 and 35 is acceptable. | prefer 25 inches
per minute because it helps reduce the dot matrix effect that may
happen at higher speeds. Once you’ve entered in your feed rate, click

IIO KH
-
1 Cnline: Default Online Template M
Template ¥ Basic Cut | Lead In/Out |
Contraol Tool
Lv L =] ]

Offset
Flasma

Flasma 1004 1,2 MILD STEEL
Flasma 1004 1/4 MILD STEEL
Plasma 1504 1/2 MILD STEEL
Flasma 50A 1/8 MILD STEEL
Flasma Fine cut

Plasma FINECUT

Plate Marer

Proline 1004 378 MILD STEEL
Proline 704 174 MILD STEEL
Proline 704 178 MILD STEEL
Proline 704 3716 MILD STEEL
Proline 704 378 MILD STEEL

Direction
2 Convertional % a Climbing s

Mave Contral

Power I ﬂ'::ll
Dwell time: I ﬂ,ﬂ-l]-l}::i 5

lock Template | 4dd |  Change | ok | Cancel | o Hep |

o
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Select the rectangle and go to [Machine > Create Tool Path > Male].

File Edit Layout Amange [Machine | Transform Image View Options Help

Output... AP gss 2 1o 3y G oo AR

Machining Defaults T 3397 gmﬂﬂﬂﬂ éll"/, j !

T o LY L 7 PIET FCIEL Y

BT E | o | | z | H | 4 | 5 7 g o

Cut Template...

Tool Library...

Material Library...

Use Easy Templates “

Cut Template Wizard

Create Tool Path 3 Online...

Apply Tool Path 3 Male...

Delete Tool Path Female...

Edit Tool Path... Fill...

Convert To Online Tool Path Torch Path [t = Bl
Edit Start Point Drill Matrix...

Ly Drill Contour...

Obiject Total Area Drill Center... ™

Drill Corner...
b “ i} 5]
o
“ u = al

e I

Pretty much the same rules apply in this tool path creation as they did
when you created an online path. You’ll need to choose your tool, set
your direction, and choose your feed rate. All of these things are
important to make sure your file works properly when you open it up
inside of the Torchmate software.
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(1)Select your plasma tool. (2)Select “Climbing” for your direction.
(3)Enter in your feed rate.

|~ '1
Male: Default Male Template u

Template + Basic Cut | v Lead In/Out |

Contraol Toal

E == < _ |
Cffset

Plasma
Plasma 1004 1/2 MILD STEEL
Plasma 1004 1/4 MILD STEEL
Plasma 1504 1,2 MILD STEEL
Plasma 50A 1/8 MILD STEEL
Plasma Fine cut
1 Plasma FINECUT
Plate Marker
Proline 1004 378 MILD STEEL
Praoline 704 174 MILD STEEL
Proline 704 178 MILD STEEL
Proline 704 3716 MILD STEEL
Praline 704 378 MILD STEEL

— Direction
Convertional ‘ 2 Climbing % s

— Tool Path Comering
Roll ¢ @

Power B %
Dwvell time: I D.D‘DD::II 3
lock Template | 4dd | Change [[ ok |  Canesl | Hep |

— Move Control

3

Now move on to your “Lead In/Out” tab and adjust your lead ins as you
see fit. Afterwards, click “OK”.
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Now would be a good time to save your progress [File > Save]. That
way if you have any problems, you can always open up your saved file
and make adjustments.

By now you should have your original drawing and your tool path on
the screen.

At this point, getting the file in the right order is crucial. Even though
we made the tool path on the circle first, that doesn’t necessarily mean
it will start at the circle.
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To check and correct this, we need to go to the sequence manager. To
go [Layout > Sequence > Start Sequence By List].

File EditArrange Machine Transform  Image View Options Help

Size [ Mave Y e oo 4 1ooom0 G 0.000
Arrange and Distribute 3 :I I oo i' 100,000 ==

Group Ctrl+13 Q @I @ Wy ﬂ
L .'::f iy a

Ungl.cup 'I:li'lt+G I|||.|||I||.-:I;5|||I|||-.|||I||

Ungroup All |

Array...

Auto Layout..,
Sequence L Start Sequence

Badges... Start Sequence by Vector
Page Control... Start Sequence by List
Go To Page... Start Sequence by Traits

Templates L

Clip Art Go To 3
Clip Art Viewer

Clip Art Categories Setup

Custom Parts...

Commen Line Cutting r

Material Size...

Material Blank Object

E

It will show you the objects you currently have in the program and list

them in their cut order.
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We won’t be concerned with regular objects, so click on “Tool Paths
Only”

I 1 .

Sequence by List

1 I Fe=ctangle

2 . Circle

3 [ Toel Path

4 OTDD| Path I
Set T -1

’ Tool Paths Only

Sign blank only

Ize zhift key ta navigate without chanaging arder.

k., Cancel

29

——
| —



You should see something like this after click that button:

r =

Sequence by List

To Front

1 [ 1Tool Path

2 O Tool Path ToBack

Forward One

Back One

Feverze Order

Sef Tar ”1_

I Tool Paths Only

Sign blank only |

Idze shift key to navigate withaut changing arder.

] I Cancel |

n 4

.

To alter the cut order, click on the object you want to move and then
use the buttons to the right to move it in a direction. In this case, we
want to take the circle and move it “To Front”.

F B
Sequence by List u

To Back |

2 [ Tool Path

Fonward One I
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After that, click “OK”. Now we need to export this file to G-Code. Go to
[View > Show Tool Paths Only].

File Edit Layout Arrange Machine Transform Image | View

Objectz: 0
[-3.663,11.008

i

PERCENGEPLOE>Ry

|G|||||||?|||||||8|||||||g|||||||1u|||||||1ﬁ|

v

<

<

Show Material Blank
Show Fill

Show Bitmap Outlines
Link Show Fill and Bitmap Outlines
Show Tool Diameter
Show Tool Paths

Show Tool Paths Only
Show Tool Path Viewer
Show Rulers

Show Bridges

Show 3D

Show Bitmaps Only
Show Reduced Bitraps
Show Grid

Show Guide Labels
Palettes

Toolbars

Show InstantReplay
Show Storage Bin

Alt+5
Alt+A

Alt+M

Alt+)

Alt+R

Alt+]

So now all that should be visible is your tool path.

It is important that you now take the tool paths and move them to the
zero location on the grid space.

31

——
| —



Now select both the circle and rectangle and go to [Machine > Output].

File Edit Layout

Machining Defaults
Tool Options...
Tiling...

Cut Template...
Tool Library...
Material Library...

Use Easy Templates

Cut Template Wizard

Create Tool Path

Apply Tool Path

Delete Tool Path

Edit Tool Path...

Convert To Online Tool Path
Edit Start Point

Job Analysis

Object Total Area

P

Arrange | Machine | Transform  Image View Options Help

Output... g

v a3 100000 j/ ¢ oomo P

T 355 2 1o00m j/ !

L B o 9 58 ¥

-'E”II”-'4”"”-'ZIIIIII-'-:”I ..._:... ...JE... |||_4|||I|||_2|||I|||.|||I|||2|||I|||4|||I|||D|||I|||5|||I|||
! 8 m|

T

= m
O = £

At this point, a bar will pop up with a whole lot of icons on it. For this

guide, we will only be concerned with two of them. Click the calculator

Tool  ulti-tool

=[]

icon to generate the G-Code.

Repeatz: & 100 EIEIEI

I T muuuuj

Device Torchmate Dual Toc + .| 1 i“:l

= o (0000 |4

x: [0.000
.v 0.000 I. T (0000 :||

.|.......|...E?2...|...3!':'...|...*.:'...

Izul 1

I1EI 1

——
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This will generate the G-Code on the right hand of the screen. It should

look like this:
|1.?4|||||||1|12|||||||1?3|||||||1?B||
MOE T2
G43H2
GO0 =5.224 41,863
ME0

GOZ<4.111%2.97610.0001.113 F25.000
G0Z<5.224v4.08311.11 310,000
GOZ4E. 3372 597610.000-1.113
GOZ<5.224%1.8621-1.113]0.000
M5

GO0 X5.224 1863

MOE T1

G43H1

GOOX0.733 4,704

ME0

01 0.942'4.704 F100.000
G01#3.507 4.704

0T +9.607 %1248

GOT x0.942%1.248

GO =0.942 4. 704

M5

G000.000%0.000

MO

After that, click on the scissor icon on the same bar the calculator icon
is on.
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At this point, you will need to name your file and save it. It will
automatically select FGC as an extension. This is the native G-Code that
opens inside of the Torchmate software.

Cut Toolbox
| Qe F B i |
# Processing to file Lé]
l\_./”\../l | . v Computer ¢ OSDisk (C:) » Torchmate Data » G-Code v|$¢|| Search G-Code Pl
Organize = Mew folder = - '@'
& Downloads E Name : Date modified Type Size
2 Recent Places ) .
| Bolt.fgc 10/11/2011 7:56 AM  FGC File 2 KB
= Librar | Line speed 130-10.fgc 11/27/201310:23 ...  FGC File 1KB
ibraries
ﬁj - ; | Thick line speed test.fgc 10/11/2011 7:56 AM  FGC File 1KE
J M“L_'me" T lEl [ Tutorfye 10/11/2011 7:56 AM  FGC File 1Ke
I Music
&= Pictures
E Videos |
1M Computer
&, osDisk (C)
O o= TORCHMATE (E:
cocoo File name: M
Save as type: ’fgc (*.fgc) ']
# Hide Felders [ Save ] [ Cancel ]

After you save the file, open up your Torchmate software. Go to

[File > Open G-Codel].

i Torchmate - No G-Code File Open - Torck
| File] Edit Configuration Controller Vie

Mew G-Code... Ctrl+M
Open G-Code... rl+0
Close G-Code

Mew Setup...
Open Setup...
Save Setun
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Now just navigate to the file you just saved. Select it and then click
”Open”.

Organize * MNew folder =~ [0l @

‘v Eavorites i Name . Date modified Type
Bl Desktop || Boltfgc 10/11/2011 7:56 AM  FGC File
4 Downloads Line speed 130-10.fgc 11/27/201310:23 ..  FGCFile
<\ Recent Places || multiteoltest.fgc 12/23/201312:05 ...  FGCFile
= L Thick line speed test.fgc 10/11/2011 7:56 AM  FGC File
73 Libraries || Tutorfgc 10/11/2011 7:56 AM  FGC File
=| Docurments
‘ Music
k| Pictures
B Videos

1M Computer
&, osDisk (C3)
= TORCHMATE (E:) ~ | m b

| Al Files (.9 - |

File name: multitooltest fgc h
* [ Open ] | Cancel |

This will bring your file into the Torchmate software with all of the tool

changes and feed rates already entered in for you. All you need to do is

(1)zero out your program coordinates and (2)hit Start.

Reset Jump Prograr) [WS€i0%
Coninon 2 o | 0-v000

Y 0.0000
=N e Y B
N (| Prog FR:0.0 Adj FR: 0.0 Machine Iﬁ

W Calculate Run Time N/A

By LA B L R

W o =]

Puoint

Fun Time: MNiA To Go: MIA

E N NN N
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Call, Fax, or Email

Call us for
Consumables,
or visit our
web store

When building the table if a guestion or concern arises or a part is missing, please contact
Torchmate technical support.

Technical support will also help you with operating the CNC system, and troubleshooting
problems,

Torchmate Technical support is available Monday through Friday from 6 AM to 4 PM (06:00
to 16:00) Pacific Time Zone,

MATE

A Lincodn Elpctic Cempoimy

Toll Free: 1-866-571-1066
International: 775-673-2200
Fax: 775-673-2206
Email: support@torchmate.com
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